import Foundation
let pattern = #"[^\.]*\.(?<All>.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
TMS_KEP.Male_RTU2.Male_PRM1_GL_OUT
TMS_KEP.Male_RTU2.Male_PRM1_PS_IN
TMS_KEP.Female_RTU2.Female_WC8_RL_OUT
TMS_KEP.Male_RTU1.Male_WC3_FS_OUT
TMS_KEP.Male_RTU1.Male_WC5_FS_OUT
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)