// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-zA-Z]+(?:-[a-zA-Z]+)*$").unwrap();
let string = "John-Doe
John-Doe-Junior
-John-Doe
John-Doe-
-John-Doe-
John--Doe";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}