#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d{2}\s*\d{2})\s*[\W*]\s*(\d{3,6})"
Local $sString = "" & @CRLF & _
"серия 3204 09988, выдан 07.02.2005г, Отделом Внутренних Дел" & @CRLF & _
"" & @CRLF & _
"серия 3204 № 099881 ," & @CRLF & _
"" & @CRLF & _
"32 04 № 099881 ОВД р-на 07.02.2005г." & @CRLF & _
"" & @CRLF & _
"серия 3204 № 099881 ,lorem" & @CRLF & _
"" & @CRLF & _
"серия 3204 номер 099881, выдан 07.02.2005г, Отделом Внутренних Дел обл. код подразделения: 569-007" & @CRLF & _
"" & @CRLF & _
"паспорт 32 04 099881" & @CRLF & _
"" & @CRLF & _
"серия 32 03 818655, выдан " & @CRLF & _
"" & @CRLF & _
"серия 32 11 045497, выдан 15.03.2011г., " & @CRLF & _
"" & @CRLF & _
"Серия 3214 № 426428 Выдан 03.03.2011 Отдел " & @CRLF & _
"" & @CRLF & _
"Серия 32 10 № 980598 Выдан 03.07.2010 Отдел УФМС \" & @CRLF & _
"" & @CRLF & _
"32 08 803828 ОУФМС России по области" & @CRLF & _
"" & @CRLF & _
"Паспорт 32 14 номер 498391" & @CRLF & _
"" & @CRLF & _
"Паспорт серия 80 02 номер 279 781 по Оренбургской 31.04.2019" & @CRLF & _
"" & @CRLF & _
"Паспорт 32 10 966241" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")