import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{2}\\s*\\d{2})\\s*[\\W*]\\s*(\\d{3,6})";
final String string = "\n"
+ "серия 3204 09988, выдан 07.02.2005г, Отделом Внутренних Дел\n\n"
+ "серия 3204 № 099881 ,\n\n"
+ "32 04 № 099881 ОВД р-на 07.02.2005г.\n\n"
+ "серия 3204 № 099881 ,lorem\n\n"
+ "серия 3204 номер 099881, выдан 07.02.2005г, Отделом Внутренних Дел обл. код подразделения: 569-007\n\n"
+ "паспорт 32 04 099881\n\n"
+ "серия 32 03 818655, выдан \n\n"
+ "серия 32 11 045497, выдан 15.03.2011г., \n\n"
+ "Серия 3214 № 426428 Выдан 03.03.2011 Отдел \n\n"
+ "Серия 32 10 № 980598 Выдан 03.07.2010 Отдел УФМС \\\n\n"
+ "32 08 803828 ОУФМС России по области\n\n"
+ "Паспорт 32 14 номер 498391\n\n"
+ "Паспорт серия 80 02 номер 279 781 по Оренбургской 31.04.2019\n\n"
+ "Паспорт 32 10 966241\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}