using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\+(?:[^+\n]*\+){2}";
string input = @"+1a
+1a +2
+1a +2 +3
+1a +2 +3 +4
+1a +2 +3 +4 +5";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}