package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9_@.-]{8,}$`)
var str = `111sF-
12345678
abcA@.11
abcA@.112
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}