$re = '/^[a-zA-Z0-9_@.-]{8,}$/m';
$str = '111sF-
12345678
abcA@.11
abcA@.112
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);