#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Kerberos-wsfed:[\s\S]*Mean:\s(\d+)"
Local $sString = "Kerberos:" & @CRLF & _
" Historical:" & @CRLF & _
" Between 26 and 50 milliseconds: 10262" & @CRLF & _
" Between 50 and 100 milliseconds: 658" & @CRLF & _
" Between 101 and 200 milliseconds: 9406" & @CRLF & _
" Between 201 and 500 milliseconds: 6046" & @CRLF & _
" Between 501 milliseconds and 1 second: 1646" & @CRLF & _
" Between 1 and 5 seconds: 1399" & @CRLF & _
" Between 6 and 10 seconds: 13" & @CRLF & _
" Between 11 and 30 seconds: 34" & @CRLF & _
" Between 31 seconds and 1 minute: 7" & @CRLF & _
" Between 1 minute and 2 minutes: 1" & @CRLF & _
" Mean: 268, Mode: 36, Median: 123" & @CRLF & _
" Total: 29472" & @CRLF & _
" Kerberos-wsfed:" & @CRLF & _
" Historical:" & @CRLF & _
" Between 26 and 50 milliseconds: 3151" & @CRLF & _
" Between 50 and 100 milliseconds: 129" & @CRLF & _
" Between 101 and 200 milliseconds: 650" & @CRLF & _
" Between 201 and 500 milliseconds: 411" & @CRLF & _
" Between 501 milliseconds and 1 second: 171" & @CRLF & _
" Between 1 and 5 seconds: 119" & @CRLF & _
" Between 6 and 10 seconds: 4" & @CRLF & _
" Between 11 and 30 seconds: 6" & @CRLF & _
" Between 1 minute and 2 minutes: 1" & @CRLF & _
" Mean: 176, Mode: 33, Median: 37" & @CRLF & _
" Total: 4642" & @CRLF & _
"" & @CRLF & _
"^.*?(?=Kerberos-wsfed:.*Mean:\s)\d+"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")