# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Kerberos-wsfed:[\s\S]*Mean:\s(\d+)"
test_str = ("Kerberos:\n"
" Historical:\n"
" Between 26 and 50 milliseconds: 10262\n"
" Between 50 and 100 milliseconds: 658\n"
" Between 101 and 200 milliseconds: 9406\n"
" Between 201 and 500 milliseconds: 6046\n"
" Between 501 milliseconds and 1 second: 1646\n"
" Between 1 and 5 seconds: 1399\n"
" Between 6 and 10 seconds: 13\n"
" Between 11 and 30 seconds: 34\n"
" Between 31 seconds and 1 minute: 7\n"
" Between 1 minute and 2 minutes: 1\n"
" Mean: 268, Mode: 36, Median: 123\n"
" Total: 29472\n"
" Kerberos-wsfed:\n"
" Historical:\n"
" Between 26 and 50 milliseconds: 3151\n"
" Between 50 and 100 milliseconds: 129\n"
" Between 101 and 200 milliseconds: 650\n"
" Between 201 and 500 milliseconds: 411\n"
" Between 501 milliseconds and 1 second: 171\n"
" Between 1 and 5 seconds: 119\n"
" Between 6 and 10 seconds: 4\n"
" Between 11 and 30 seconds: 6\n"
" Between 1 minute and 2 minutes: 1\n"
" Mean: 176, Mode: 33, Median: 37\n"
" Total: 4642\n\n"
"^.*?(?=Kerberos-wsfed:.*Mean:\\s)\\d+")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.