// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*\/d\/([a-zA-Z]*)\/.*\/(\d+_\d+\.mp4).*").unwrap();
let string = "var a = 776644%94536;
document.getElementById('dlbutton').href = \"/d/lHCIDyYJ/\"+a+\"/2842_4.mp4\";
if (document.getElementById('fimage')) {
document.getElementById('fimage').href = \"/i/lHCIDyYJ/\"+a+\"/2842_4.mp4\";
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}