$re = '/[0x\w]*/m';
$str = '#define Error_Failed_To_Do_A 0x81A0 /* random comments */';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);