re = /[0x\w]*/m
str = '#define Error_Failed_To_Do_A 0x81A0 /* random comments */'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end