#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[A-Z\h-]+: .*"
Local $sString = "" & @CRLF & _
"BYLINE: BAS HAKKERS" & @CRLF & _
"" & @CRLF & _
"SECTION: Media; Blz. 33" & @CRLF & _
"" & @CRLF & _
"LENGTH: 355 woorden" & @CRLF & _
"" & @CRLF & _
"HIGHLIGHT: Verkiezingen Robert Jensen keert vanaf vandaag terug op de" & @CRLF & _
"Nederlandse televisie. In 'Jensen kiest voor Amerika' onderzoekt hij de" & @CRLF & _
"aantrekkingskracht van Donald Trump. Is hij definitief terug of lonkt misschien" & @CRLF & _
"een oude liefde?" & @CRLF & _
"" & @CRLF & _
"Waarom ben je Jensen kiest voor Amerika gaan maken?" & @CRLF & _
"" & @CRLF & _
",,Ik vind Amerika al mijn hele leven een fascinerend land, ben er vaak en volg" & @CRLF & _
"de verkiezingen als fenomeen. Toen Trump maar bleef winnen, begon het idee voor" & @CRLF & _
"een tv-programma te leven. Ik wilde alles van die Trump-aanhangers weten want" & @CRLF & _
"daar hoor je weinig over.''" & @CRLF & _
"" & @CRLF & _
"Wat mis je in de berichtgeving?" & @CRLF & _
"" & @CRLF & _
",,De media zijn op de hand van Hillary en Trump is vijand nummer één. En je" & @CRLF & _
"krijgt in Europa te zien wat er gebeurt in Hollywood en New York, maar hoort" & @CRLF & _
"niets over de staten daartussenin. Daar wonen mensen met een compleet andere" & @CRLF & _
"mentaliteit die wij niet zullen herkennen.''" & @CRLF & _
"" & @CRLF & _
"Kun je een voorbeeld noemen?" & @CRLF & _
"" & @CRLF & _
",,Ik ben in Mingo Junction geweest, een kleine stad in de staat Ohio. Vroeger" & @CRLF & _
"was dat een bloeiende gemeenschap met veel staalbouw, maar die is naar China" & @CRLF & _
"verdwenen. Mensen die ik in dat verwaarloosde stadje spreek, hebben geen idee" & @CRLF & _
"waarmee de gemiddelde man of vrouw uit New York bezig is. Die gasten kunnen er" & @CRLF & _
"niet bij dat het in de media over transgendertoiletten gaat, terwijl zij geen" & @CRLF & _
"baan hebben en er een gigantisch drugsprobleem is.''" & @CRLF & _
"" & @CRLF & _
"Wat zien zij in Trump?" & @CRLF & _
"" & @CRLF & _
",,Ze denken dat Donald Trump die banen gaat terugbrengen en zien zo'n politiek" & @CRLF & _
"incorrecte, succesvolle zakenman die geen blad voor de mond neemt als dé" & @CRLF & _
"mogelijkheid om te ontsnappen aan hun ellende. Hillary Clinton staat voor de" & @CRLF & _
"status quo, terwijl zij juist verandering willen.''" & @CRLF & _
"" & @CRLF & _
"Je was in 2013 voor het laatst op televisie. Heb je tv-maken gemist?" & @CRLF & _
"" & @CRLF & _
",,Ik zit niet te huilen omdat ik niet op tv ben. Altijd heb ik in studio's" & @CRLF & _
"gewerkt. Nu trek ik erop uit en kom ik op mooie plekken. Daar hoor je goe-de" & @CRLF & _
"verhalen. Dat ga ik waarschijnlijk wel vaker doen.''" & @CRLF & _
"" & @CRLF & _
"En een talkshow?" & @CRLF & _
"" & @CRLF & _
",,Daarvoor zijn geen concrete plannen. Ik heb dat twaalf jaar gedaan, waarvan" & @CRLF & _
"drie jaar dagelijks. Ik denk dat er nog steeds ruimte is voor zo'n mix van" & @CRLF & _
"inhoudelijke gesprekken, nieuwtjes en entertainment. Dat format is tijdloos, dat" & @CRLF & _
"kun je altijd weer oppakken.''" & @CRLF & _
"" & @CRLF & _
"En radio maken?" & @CRLF & _
"" & @CRLF & _
",,Ik ben met wat interessante ideeën bezig. Concreet kan ik nog zijn, zo ver is" & @CRLF & _
"het gewoon nog niet.''" & @CRLF & _
"" & @CRLF & _
"Jensen kiest voor Amerika, RTL 5, 21.50 uur." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"VIEW ORIGINAL PAGE: " & @CRLF & _
"" & @CRLF & _
"LOAD-DATE: 19 October 2016" & @CRLF & _
"" & @CRLF & _
"LANGUAGE: DUTCH; NEDERLANDS" & @CRLF & _
"" & @CRLF & _
"GRAPHIC: Robert Jensen: ,,Gewone Amerikanen zien Trump als een kans om te" & @CRLF & _
"ontsnappen aan hun ellende.''" & @CRLF & _
"" & @CRLF & _
"PUBLICATION-TYPE: Krant" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" Copyright 2016 De Persgroep Nederland BV" & @CRLF & _
" All Rights Reserved"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")