#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^ *(\d *){6,10}$"
Local $sString = "1 2345" & @CRLF & _
"123 45" & @CRLF & _
"12345" & @CRLF & _
"123 45678912" & @CRLF & _
"" & @CRLF & _
"1 23456" & @CRLF & _
"123 456" & @CRLF & _
"123456 789 1" & @CRLF & _
"12 345 678 90"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")