re = /^ *(\d *){6,10}$/m
str = '1 2345
123 45
12345
123 45678912
1 23456
123 456
123456 789 1
12 345 678 90'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end