$re = '/(?:^Take|\G(?!^)).*?\Kdog/m';
$str = 'Take dog, dog, dog, cat, dog;
Dont dog, dog, cat, dog;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);