re = /(?:^Take|\G(?!^)).*?\Kdog/m
str = 'Take dog, dog, dog, cat, dog;
Dont dog, dog, cat, dog;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end