#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^\S\r\n]*@hi\b[^\S\r\n]*{[^{}]*}"
Local $sString = "hello{" & @CRLF & _
" @hi {" & @CRLF & _
" I want this text" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" @hola {" & @CRLF & _
" I don't want this text" & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")