re = /[^\S\r\n]*@hi\b[^\S\r\n]*{[^{}]*}/m
str = 'hello{
@hi {
I want this text
}
@hola {
I don\'t want this text
}
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end