import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?>[^\\\"\\(\\s\\)]+(?>(?>\\\"[^\\\"]*\\\")[^\\\"\\(\\s\\)]*)*)|(?>[^\\\"\\(\\s\\)]*(?>(?>\\\"[^\\\"]*\\\")[^\\\"\\(\\s\\)]*)+)";
final String string = "123\n\n"
+ "\"a b c\"\n\n"
+ "f\"Hello, {world}!\"\n\n"
+ "\"multi-line\n"
+ "strings\"\n\n"
+ "text-before-the-quote\"text in the quote\"text-after-the-quote\n\n"
+ "[]{}<>-are-also\"atoms since we only care about ()\"<-notice_we_had_to_escape\"(\"and\")\"\n\n"
+ "emoji.too:🗿:😂";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}