import re
regex = re.compile(r"(?>[^\"\(\s\)]+(?>(?>\"[^\"]*\")[^\"\(\s\)]*)*)|(?>[^\"\(\s\)]*(?>(?>\"[^\"]*\")[^\"\(\s\)]*)+)")
test_str = ("123\n\n"
"\"a b c\"\n\n"
"f\"Hello, {world}!\"\n\n"
"\"multi-line\n"
"strings\"\n\n"
"text-before-the-quote\"text in the quote\"text-after-the-quote\n\n"
"[]{}<>-are-also\"atoms since we only care about ()\"<-notice_we_had_to_escape\"(\"and\")\"\n\n"
"emoji.too:🗿:😂")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")