#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?!.{36,})[a-z'-]{2,}\s[a-z'-]{2,}"
Local $sString = "Bartholomew Jamieson-Smithson-West " & @CRLF & _
"Mellisa Wu" & @CRLF & _
"Li Smith " & @CRLF & _
"Andy Bartholomew-Jamieson-Smithson-West" & @CRLF & _
"L Bartholomew-Jamieson-Smithson-Wu"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")