const regex = /^(?!.{36,})[a-z'-]{2,}\s[a-z'-]{2,}/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.{36,})[a-z\'-]{2,}\\s[a-z\'-]{2,}', 'gmi')
const str = `Bartholomew Jamieson-Smithson-West
Mellisa Wu
Li Smith
Andy Bartholomew-Jamieson-Smithson-West
L Bartholomew-Jamieson-Smithson-Wu`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}