using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<code>\s*<pre>\s*<code>\s*<pre>";
string input = @"<code>
<pre>
<code>
<pre>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}