package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<code>\s*<pre>\s*<code>\s*<pre>`)
var str = `<code>
<pre>
<code>
<pre>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}