use strict;
my $str = 'Real Estate
';
my $regex = qr/(?:(\w+)\s?\b)/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";