package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^[-a-z0-9 ,#'\/.]{3,50}$`)
var str = `123 1/2 S. Main St. Apt. 1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}