$re = '/^[-a-z0-9 ,#\'\/.]{3,50}$/i';
$str = '123 1/2 S. Main St. Apt. 1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);