import re
regex = re.compile((r"((LOOP\s+AT\s+\w*\s+INTO\s+\w*(.?)\s+)((INSERT|DELETE|UPDATE|MODIFY)\s+(\w*\.?\*?\s+)*(FROM\s+\w*\.\s*)?(ENDLOOP\.)))\n\n"), flags=re.MULTILINE | re.IGNORECASE)
test_str = ("LOOP AT TAB \n"
" INTO TAB_WA.\n"
" INSERT INTO CUSTOMERS VALUES TAB_WA.\n"
"ENDLOOP.\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")