using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\\\\)\s";
string input = @"us-west,AAA 4589235i date=Wed\\ Dec\\ 12\\ 02:27:22\\ UTC\\ 2018";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}