import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*\\\\r\\\\n\\|\\*(Task 1)\\*\\|(.*)\\|(.*)\\|(.*)\\|(.*)\\|\\\\r\\\\n\\|\\*(Task 2)\\*\\|(.*)\\|(.*)\\|(.*)\\|(.*)\\|\\\\r\\\\n\\|\\*(Task 3)\\*\\|(.*)\\|(.*)\\|(.*)\\|(.*)\\|\\\\r\\\\n\\|\\*(Task 4)\\*\\|(.*)\\|(.*)\\|(.*)\\|(.*)\\|$";
final String string = "|| ||Du Date||Done on||OK/NOK||Remarks||\\r\\n|*Task 1*| | | | |\\r\\n|*Task 2*| | | | |\\r\\n|*Task 3*| | | | |\\r\\n|*Task 4*| 15/03/23| | | See document X|";
final String subst = "{\"ACTION\":[{\"TITLE\":\"$1\",\"DUE DATE\":\"$2\",\"DONE ON\":\"$3\",\"NOTE\":\"$5\"},{\"TITLE\":\"$6\",\"DUE DATE\":\"$7\",\"DONE ON\":\"$8\",\"NOTE\":\"$10\"},{\"TITLE\":\"$11\",\"DUE DATE\":\"$12\",\"DONE ON\":\"$13\",\"NOTE\":\"$15\"},{\"TITLE\":\"$16\",\"DUE DATE\":\"$17\",\"DONE ON\":\"$8\",\"NOTE\":\"$20\"}]}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}