# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.*\\r\\n\|\*(Task 1)\*\|(.*)\|(.*)\|(.*)\|(.*)\|\\r\\n\|\*(Task 2)\*\|(.*)\|(.*)\|(.*)\|(.*)\|\\r\\n\|\*(Task 3)\*\|(.*)\|(.*)\|(.*)\|(.*)\|\\r\\n\|\*(Task 4)\*\|(.*)\|(.*)\|(.*)\|(.*)\|$"
test_str = "|| ||Du Date||Done on||OK/NOK||Remarks||\\r\\n|*Task 1*| | | | |\\r\\n|*Task 2*| | | | |\\r\\n|*Task 3*| | | | |\\r\\n|*Task 4*| 15/03/23| | | See document X|"
subst = "{\"ACTION\":[{\"TITLE\":\"$1\",\"DUE DATE\":\"$2\",\"DONE ON\":\"$3\",\"NOTE\":\"$5\"},{\"TITLE\":\"$6\",\"DUE DATE\":\"$7\",\"DONE ON\":\"$8\",\"NOTE\":\"$10\"},{\"TITLE\":\"$11\",\"DUE DATE\":\"$12\",\"DONE ON\":\"$13\",\"NOTE\":\"$15\"},{\"TITLE\":\"$16\",\"DUE DATE\":\"$17\",\"DONE ON\":\"$8\",\"NOTE\":\"$20\"}]}"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.