package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([\+\(\)\-0-9 ]*)([A-Za-z' ]*)$`)
var str = `123-456-7890 Betty's cell
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}