package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<ignored_group><name=".+">)|(?<matched_group>[_!=+])`)
var str = `cat_dog_ !mouse= <name="Jake_Russell!"> gog+cat`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}