$re = '/(?<ignored_group><name=".+">)|(?<matched_group>[_!=+])/m';
$str = 'cat_dog_ !mouse= <name="Jake_Russell!"> gog+cat';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);