#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:Wertmindernde Faktoren|Gebrauchsspuren.*)\n(.*(?:\n.+)*)"
Local $sString = "Vordersitze beheizbar" & @CRLF & _
"Vordersitze elektrisch einstellbar, Fahrersitz mit Memory, Komforteinstieg, längs verschiebbarer" & @CRLF & _
"Oberschenkelauflage" & @CRLF & _
"Wegfahrsperre elektronisch" & @CRLF & _
"" & @CRLF & _
"20.07.2021 Gutachtennummer: XXXXXXX Seite 6 / 17TÜV SÜD Auto Plus GmbH Fahrzeugbewertung" & @CRLF & _
" Wiesenring 2" & @CRLF & _
" 04159 Leipzig" & @CRLF & _
" +XXXXXXXXXXXX" & @CRLF & _
"GUTACHTENNUMMER: XXXXXX" & @CRLF & _
"Bei Rückfragen bitte Gutachtennummer und Datum angeben Datum: 20.07.2021" & @CRLF & _
"" & @CRLF & _
"Ausstattung" & @CRLF & _
"Zentralverriegelung ohne Safe-Sicherung,mit Funkfernbedienung, 2 Funkschlüssel, Komfortstartfunktion" & @CRLF & _
""Press & Drive"" & @CRLF & _
"" & @CRLF & _
"Wertmindernde Faktoren" & @CRLF & _
"Nr. Bauteilgruppe Beschreibung" & @CRLF & _
"1 Heckklappe/-tür Heckklappe - Dellen - sanft instandsetzen" & @CRLF & _
"" & @CRLF & _
"Gebrauchsspuren" & @CRLF & _
"Nr. Bauteilgruppe Beschreibung" & @CRLF & _
"1 Stossfänger vorn Spoiler (Unterhalb) - Kratzer - kein Abzug" & @CRLF & _
"2 Stossfänger hinten Stossfänger hinten - Kratzer - kein Abzug" & @CRLF & _
"3 Tür hinten rechts Tür - Dellen - kein Abzug" & @CRLF & _
"4 Tür vorn rechts Tür - Dellen - kein Abzug" & @CRLF & _
"" & @CRLF & _
"Vorschaden" & @CRLF & _
"Nr. Vorschaden Schadenshöhe" & @CRLF & _
"1 fachgerecht repariert , Reparaturrechnung nicht vorhanden 311,10 €" & @CRLF & _
"2 fachgerecht repariert , Reparaturrechnung nicht vorhanden 493,31 €" & @CRLF & _
"3 Seite links, fachgerecht repariert , Reparaturrechnung nicht vorhanden" & @CRLF & _
"" & @CRLF & _
"Summe (netto): 804,41 €" & @CRLF & _
"" & @CRLF & _
"Nachlackierungen" & @CRLF & _
"Nr. Ort" & @CRLF & _
"1 Tür vorne links, fachgerecht ausgeführt" & @CRLF & _
"" & @CRLF & _
"Hinweise zum Gutachten" & @CRLF & _
"Angaben zum Auftrag und zum Begutachtungsumfang:" & @CRLF & _
"Es wurde der Auftrag erteilt, eine Fahrzeugbewertung über das beschriebene Fahrzeug zu erstellen."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")