import re
regex = re.compile(r"(?:Wertmindernde Faktoren|Gebrauchsspuren.*)\n(.*(?:\n.+)*)", flags=re.MULTILINE)
test_str = ("Vordersitze beheizbar\n"
"Vordersitze elektrisch einstellbar, Fahrersitz mit Memory, Komforteinstieg, längs verschiebbarer\n"
"Oberschenkelauflage\n"
"Wegfahrsperre elektronisch\n\n"
"20.07.2021 Gutachtennummer: XXXXXXX Seite 6 / 17TÜV SÜD Auto Plus GmbH Fahrzeugbewertung\n"
" Wiesenring 2\n"
" 04159 Leipzig\n"
" +XXXXXXXXXXXX\n"
"GUTACHTENNUMMER: XXXXXX\n"
"Bei Rückfragen bitte Gutachtennummer und Datum angeben Datum: 20.07.2021\n\n"
"Ausstattung\n"
"Zentralverriegelung ohne Safe-Sicherung,mit Funkfernbedienung, 2 Funkschlüssel, Komfortstartfunktion\n"
"\"Press & Drive\"\n\n"
"Wertmindernde Faktoren\n"
"Nr. Bauteilgruppe Beschreibung\n"
"1 Heckklappe/-tür Heckklappe - Dellen - sanft instandsetzen\n\n"
"Gebrauchsspuren\n"
"Nr. Bauteilgruppe Beschreibung\n"
"1 Stossfänger vorn Spoiler (Unterhalb) - Kratzer - kein Abzug\n"
"2 Stossfänger hinten Stossfänger hinten - Kratzer - kein Abzug\n"
"3 Tür hinten rechts Tür - Dellen - kein Abzug\n"
"4 Tür vorn rechts Tür - Dellen - kein Abzug\n\n"
"Vorschaden\n"
"Nr. Vorschaden Schadenshöhe\n"
"1 fachgerecht repariert , Reparaturrechnung nicht vorhanden 311,10 €\n"
"2 fachgerecht repariert , Reparaturrechnung nicht vorhanden 493,31 €\n"
"3 Seite links, fachgerecht repariert , Reparaturrechnung nicht vorhanden\n\n"
"Summe (netto): 804,41 €\n\n"
"Nachlackierungen\n"
"Nr. Ort\n"
"1 Tür vorne links, fachgerecht ausgeführt\n\n"
"Hinweise zum Gutachten\n"
"Angaben zum Auftrag und zum Begutachtungsumfang:\n"
"Es wurde der Auftrag erteilt, eine Fahrzeugbewertung über das beschriebene Fahrzeug zu erstellen.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")