package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`data:(?<mimetype>(?<mimetype_type>.+?)\/(?<mimetype_subtype>.+?));(?<dataencoding>.+?),(?<data>.+)`)
var str = `data:image/png;base64,iVBORw0KGgoAAAANSUhEUgA`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}