re = /data:(?<mimetype>(?<mimetype_type>.+?)\/(?<mimetype_subtype>.+?));(?<dataencoding>.+?),(?<data>.+)/
str = 'data:image/png;base64,iVBORw0KGgoAAAANSUhEUgA'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end