import re
regex = re.compile(r"^.{5}$", flags=re.MULTILINE)
test_str = ("--- NFC (o \"á\" é representado como um único code point: U+00E1)\n"
"sabiá\n"
"--- NFD (o \"á\" é representado como dois code points: U+0061 U+0301)\n"
"sabiá")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")