#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d{2}-\d{2}-\d{4}\h+\d{2}:\d{2}:\d{2})\h+-\h*(.*(?:\R(?!\d{2}-\d{2}-\d{4}\h+\d{2}:\d{2}:\d).*)*)"
Local $sString = "28-03-2020 23:00:00 - This" & @CRLF & _
"is" & @CRLF & _
"line" & @CRLF & _
"1" & @CRLF & _
"" & @CRLF & _
"28-03-2021 14:23:15 - This" & @CRLF & _
"is" & @CRLF & _
"line" & @CRLF & _
"2" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"28-03-2020 23:00:00 - This" & @CRLF & _
"is" & @CRLF & _
"12" & @CRLF & _
"line" & @CRLF & _
"1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")