re = /^(\d{2}-\d{2}-\d{4}\h+\d{2}:\d{2}:\d{2})\h+-\h*(.*(?:\R(?!\d{2}-\d{2}-\d{4}\h+\d{2}:\d{2}:\d).*)*)/m
str = '28-03-2020 23:00:00 - This
is
line
1
28-03-2021 14:23:15 - This
is
line
2
28-03-2020 23:00:00 - This
is
12
line
1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end