$re = '/^(?=[^\d\n]*\d)(?=[^!-\/:-@[-`{-~\n]*[!-\/:-@[-`{-~]).*/m';
$str = 'abc-
_=-!@#
123-
a1c-';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);