#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\+?\d?\s*\(?\d{3}\)?\s*\d{3}-\d{2}-\d{2}"
Local $sString = "" заказать звонок" & @CRLF & _
"" & @CRLF & _
" +7 499 399-57-07" & @CRLF & _
"" & @CRLF & _
" +7 499 347-57-07" & @CRLF & _
"" & @CRLF & _
" 01VVK@BK.RU" & @CRLF & _
"" & @CRLF & _
"ПН-ЧТ 9.00-18.00 ПТ-ПТ 9.00-17.00" & @CRLF & _
"" & @CRLF & _
"Моя корзина" & @CRLF & _
"↓" & @CRLF & _
"0" & @CRLF & _
"Список пожеланий" & @CRLF & _
"↓" & @CRLF & _
" Сравнение 0" & @CRLF & _
" " & @CRLF & _
" Закладки 0" & @CRLF & _
" " & @CRLF & _
" Корзина 0 Ваша корзина пуста" & @CRLF & _
" " & @CRLF & _
"Оформить заказ" & @CRLF & _
"КАТАЛОГ" & @CRLF & _
"АРЕНДА" & @CRLF & _
"О МАГАЗИНЕ" & @CRLF & _
"ОПЛАТА И ДОСТАВКА" & @CRLF & _
"ПРАЙСЫ" & @CRLF & _
"КОНТАКТЫ" & @CRLF & _
"" & @CRLF & _
" +7 499 399-57-07" & @CRLF & _
"" & @CRLF & _
"ИНТЕРНЕТ-МАГАЗИН ЛЕСТНИЦ И СТРЕМЯНОК "МИР СТРЕМЯНОК"" & @CRLF & _
"" & @CRLF & _
"Интернет-магазин "Мир Стремянок.ру" предлагает вашему вниманию качественные лестницы-стремянки, вышки туры и подмости, выполненные из современных безопасных материалов и доступные для покупки в Москве по максимально выгодным ценам!" & @CRLF & _
"" & @CRLF & _
"Мы предлагаем качественное оборудование для строительных и ремонтных работ, которое является залогом отменно выполненной поставленной задачи, безопасности строителей, а также существенной экономии времени. Благодаря бытовым и профессиональным алюминиевым лестницам, стремянкам, подмости и вышкам турам от лучших иностранных производителей вы забудете о поломках инструмента, коррозии материала или неудобствах." & @CRLF & _
"" & @CRLF & _
"СТРЕМЯНКИ" & @CRLF & _
" " & @CRLF & _
"ЛЕСТНИЦЫ" & @CRLF & _
" " & @CRLF & _
"ПОДСТАВКИ" & @CRLF & _
" " & @CRLF & _
"ВЫШКИ ТУРЫ" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"ПОДМОСТИ" & @CRLF & _
" " & @CRLF & _
"ДЕРЕВЯННЫЕ СТРЕМЯНКИ" & @CRLF & _
" " & @CRLF & _
"ШАРНИРНЫЕ" & @CRLF & _
"ЛЕСТНИЦЫ" & @CRLF & _
" " & @CRLF & _
"СПЕЦИАЛЬНЫЕ" & @CRLF & _
"ЛЕСТНИЦЫ" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"ЛЕСТНИЦЫ" & @CRLF & _
"С ПЛАТФОРМОЙ" & @CRLF & _
" " & @CRLF & _
"ЯЩИКИ И КЕЙСЫ" & @CRLF & _
" " & @CRLF & _
"АКСЕССУАРЫ" & @CRLF & _
" " & @CRLF & _
"КОЛЕСА И РОЛИКИ" & @CRLF & _
"" & @CRLF & _
"УДОБНАЯ СИСТЕМА ВОЗВРАТОВ ТОВАРА" & @CRLF & _
"БЫСТРАЯ ДОСТАВКА ПО ВСЕЙ РОССИИ" & @CRLF & _
"СПЕЦПРЕДЛОЖЕНИЯХИТЫ ПРОДАЖНОВИНКИ" & @CRLF & _
"" & @CRLF & _
"СТРЕМЯНКА ALTREX DOUBLE DECKER, 5 СТУПЕНЕЙ" & @CRLF & _
"9650 руб." & @CRLF & _
" купить " & @CRLF & _
"ПРОФЕССИОНАЛЬНАЯ ЧЕТЫРЕХСЕКЦИОННАЯ ШАРНИРНАЯ ЛЕСТНИЦА 4Х4 KRAUSE STABILO" & @CRLF & _
"19400 руб." & @CRLF & _
" купить " & @CRLF & _
"ДЕРЕВЯННАЯ СТРЕМЯНКА-ХОДУЛЯ БАЛЧУГ 2Х5 LINE (АРТ.2515L)" & @CRLF & _
"3900 руб." & @CRLF & _
" купить " & @CRLF & _
"" & @CRLF & _
"ПРЕИМУЩЕСТВА РАБОТЫ С НАМИ" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Большой ассортимент товаров" & @CRLF & _
"" & @CRLF & _
"В каталоге интернет-магазина представлено более 1000 наименований лестниц и стремянок различных групп назначения." & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Доступные" & @CRLF & _
"цены" & @CRLF & _
"" & @CRLF & _
"Прямые поставки от производителей помогают минимизировать торговую наценку." & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Отменное качество продукции" & @CRLF & _
"" & @CRLF & _
"Все реализуемые товары имеют соответствующие сертификаты качества, полученные производителями." & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Персональный" & @CRLF & _
"подход" & @CRLF & _
"" & @CRLF & _
"Наши специалисты помогут подобрать лестницу стремянку для ваших нужд." & @CRLF & _
"" & @CRLF & _
""Мир Стремянок.ру" – это место, где вы можете купить недорогую лестницу, стремянку. В интернет-магазине создан максимально удобный интерфейс, который без труда поможет вам сориентироваться в большом разнообразии представленных товаров. Совершить покупки, не выходя их своего офиса или дома, стало намного проще. Достаточно воспользоваться каталогом, представленным на сайте." & @CRLF & _
"" & @CRLF & _
"Каталог включает в себя сертифицированные товары, которые всегда есть в наличии. В ассортименте представлены лестницы и стремянки от зарубежных и отечественных производителей. Благодаря прямым поставкам и налаженной работе с поставщиками нашу продукцию отличает высокое качество и невысокая цена без накруток." & @CRLF & _
"" & @CRLF & _
"Ознакомиться с точными характеристиками и особенностями изделий вы можете на странице с товаром. Такие параметры, как высота, количество ступеней, вес лестницы, стремянки, предельная нагрузка в обязательном порядке указаны в описании товара." & @CRLF & _
"" & @CRLF & _
"Интернет-магазин "Мир Стремянок.ру" предлагает дешево приобрести легкие и прочные алюминиевые лестницы, и стремянки, а также изделия из дерева и других материалов, которые обладают высокой износостойкостью и рассчитаны на длительную эксплуатацию как в домашних условиях, так и на производстве, в строительстве. Здесь вы можете подобрать стремянку для библиотеки или домашнего использования, которая великолепно дополнит интерьер помещения. Среди представленных товаров без труда найдутся длинные лестницы и маленькие компактные стремянки-ступеньки." & @CRLF & _
"" & @CRLF & _
"Стремянки, лестницы и подмости промышленного назначения обладают разными техническими характеристиками, вы без труда сможете выбрать именно то изделие, которое максимально подойдет для вашей деятельности." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Покупка лестницы или стремянки, как правило, совершается с учетом многих параметров. Так, необходимо понимать, где и с какой целью будет использоваться приобретаемая лестница или стремянка; нагрузку, которая будет приходиться на покупаемое изделие. Если у вас возникли вопросы или затруднения с выбором, вы можете обратиться к нашим специалистам, позвонив по указанным на сайте телефонам." & @CRLF & _
"" & @CRLF & _
"Мы работаем с покупателями из Москвы и по всей территории России. Стоимость доставки зависит от выбора транспортной компании и удаленности заказчика от нашего магазина. Вы получите свой товар в максимально короткие сроки." & @CRLF & _
"" & @CRLF & _
"Если вам необходима консультация по какому-либо товару или помощь в выборе продукции – обращайтесь по контактным данным у нас сайте и наш менеджер предоставит квалифицированную помощью и исчерпывающую информацию по любому вопросу!" & @CRLF & _
"" & @CRLF & _
"КАТАЛОГ" & @CRLF & _
"" & @CRLF & _
"СТРЕМЯНКИ" & @CRLF & _
" " & @CRLF & _
"ЛЕСТНИЦЫ" & @CRLF & _
" " & @CRLF & _
"ПОДСТАВКИ" & @CRLF & _
" " & @CRLF & _
"ВЫШКИ ТУРЫ" & @CRLF & _
" " & @CRLF & _
"ПОДМОСТИ" & @CRLF & _
" " & @CRLF & _
"ШАРНИРНЫЕ ЛЕСТНИЦЫ" & @CRLF & _
" " & @CRLF & _
"СПЕЦИАЛЬНЫЕ ЛЕСТНИЦЫ" & @CRLF & _
" " & @CRLF & _
"ЛЕСТНИЦЫ С ПЛАТФОРМОЙ" & @CRLF & _
" " & @CRLF & _
"ЯЩИКИ И КОНТЕЙНЕРЫ" & @CRLF & _
" " & @CRLF & _
"АКСЕССУАРЫ" & @CRLF & _
" " & @CRLF & _
"КОЛЕСА И РОЛИКИ" & @CRLF & _
" " & @CRLF & _
"Товары месяца" & @CRLF & _
"ВЫШКА ТУРА ALTREX MITOWER (6.20)" & @CRLF & _
"195000 руб." & @CRLF & _
"ДЕРЕВЯННАЯ СТРЕМЯНКА-ХОДУЛЯ БАЛЧУГ 2Х5 LINE (АРТ.2515L)" & @CRLF & _
"3900 руб." & @CRLF & _
"SOLIDY СВОБОДНОСТОЯЩАЯ АЛЮМИНИЕВАЯ СТРЕМЯНКА 5 СТУП." & @CRLF & _
"3370 руб." & @CRLF & _
"ВЫШКА ТУРА ALTREX MITOWER (6.20)" & @CRLF & _
"195000 руб." & @CRLF & _
"ДЕРЕВЯННАЯ СТРЕМЯНКА-ХОДУЛЯ БАЛЧУГ 2Х5 LINE (АРТ.2515L)" & @CRLF & _
"3900 руб." & @CRLF & _
"SOLIDY СВОБОДНОСТОЯЩАЯ АЛЮМИНИЕВАЯ СТРЕМЯНКА 5 СТУП." & @CRLF & _
"3370 руб." & @CRLF & _
"ВЫШКА ТУРА ALTREX MITOWER (6.20)" & @CRLF & _
"195000 руб." & @CRLF & _
"Клиенту" & @CRLF & _
"КАК ОТРЕМОНТИРОВАТЬ СТУПЕНЬКИ У СТРЕМЯНКИ?" & @CRLF & _
"Высокие алюминиевые профессиональные стремянки обладают выда..." & @CRLF & _
"КАК ВЫБРАТЬ СТРЕМЯНКУ ДЛЯ КВАРТИРЫ?" & @CRLF & _
"Ассортимент стремянок достаточно широк, они изготавливаются..." & @CRLF & _
"ОБЗОР АЛЮМИНИЕВОЙ СТРЕМЯНКИ ALUMET (АЛЮМЕТ) 4Х4 ТЛ4044" & @CRLF & _
"При выборе лестницы многие ищут универсальные варианты, кото..." & @CRLF & _
"КАК РАЗЛОЖИТЬ ЛЕСТНИЦУ ТРАНСФОРМЕР АЛЮМЕТ 4Х4 ТЛ4044: ВИДЕО" & @CRLF & _
"Для проведения наружных и внутренних работ потребуется шарни..." & @CRLF & _
"КАК ОТРЕМОНТИРОВАТЬ СТУПЕНЬКИ У СТРЕМЯНКИ?" & @CRLF & _
"Высокие алюминиевые профессиональные стремянки обладают выда..." & @CRLF & _
"КАК ВЫБРАТЬ СТРЕМЯНКУ ДЛЯ КВАРТИРЫ?" & @CRLF & _
"Ассортимент стремянок достаточно широк, они изготавливаются..." & @CRLF & _
"ОБЗОР АЛЮМИНИЕВОЙ СТРЕМЯНКИ ALUMET (АЛЮМЕТ) 4Х4 ТЛ4044" & @CRLF & _
"При выборе лестницы многие ищут универсальные варианты, кото..." & @CRLF & _
"КАК РАЗЛОЖИТЬ ЛЕСТНИЦУ ТРАНСФОРМЕР АЛЮМЕТ 4Х4 ТЛ4044: ВИДЕО" & @CRLF & _
"Для проведения наружных и внутренних работ потребуется шарни..." & @CRLF & _
"" & @CRLF & _
"Все статьи" & @CRLF & _
"" & @CRLF & _
"+7 499 347-57-07 | 01VVK@BK.RU" & @CRLF & _
"" & @CRLF & _
"Москва, пос. Восточный, ул.Западная, дом 6, стр. 18" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"Информация" & @CRLF & _
"" & @CRLF & _
"О магазине" & @CRLF & _
"Блог" & @CRLF & _
"Оплата" & @CRLF & _
"Прайсы" & @CRLF & _
"Производители" & @CRLF & _
"Оптом" & @CRLF & _
"Доставка" & @CRLF & _
"Контакты" & @CRLF & _
"Аренда" & @CRLF & _
"Карта сайта" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"Каталог" & @CRLF & _
"" & @CRLF & _
"Стремянки" & @CRLF & _
"Подставки" & @CRLF & _
"Подмости | Ящики и кейсы" & @CRLF & _
"Деревянные стремянки | Лестницы" & @CRLF & _
"Вышки туры" & @CRLF & _
"Аксессуары | Колеса и ролики" & @CRLF & _
"Шарнирные лестницы" & @CRLF & _
"Лестницы с платформой" & @CRLF & _
"Специальные лестницы" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"К оплате принимаем" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" заказать звонок" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"Copyright © 2020 | Все права защищены" & @CRLF & _
"" & @CRLF & _
"Отправьте нам сообщение" & @CRLF & _
"Отправьте нам сообщение" & @CRLF & _
"Здравствуйте." & @CRLF & _
"У вас возникли вопросы? Мы с удовольствием ответим!" & @CRLF & _
"Бизнес-мессенджер ""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")