import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\+?\\d?\\s*\\(?\\d{3}\\)?-?\\s*\\d{3}-\\d{2}-\\d{2}";
final String string = "\" 8 800 707 77 22\n"
+ "бесплатно в России\n"
+ "+7 862 300 01 73\n\n"
+ " COVID-19 \n"
+ "АКЦИИ\n"
+ "ПРОГРАММА ЛОЯЛЬНОСТИ\n"
+ "НОВОСТИ\n"
+ "EN\n\n"
+ " МЕНЮ \n"
+ "Главная\n"
+ " Стоимость и бронирование номеров\n"
+ "Стоимость и бронирование номеров\n\n"
+ "Уважаемые гости!\n\n\n"
+ "При выборе отдыха с санаторно-курортным лечением по тарифу «Море здоровья», требуется:\n"
+ "- санаторно-курортная карта, которая выдается лечащим врачом по месту жительства;\n"
+ "- справка об отрицательных результатах лабораторных обследований в отношении новой коронавирусной инфекции COVID-19, полученной не позднее чем за 2 суток до даты отъезда в г. Сочи на каждого гостя;\n"
+ "- информация об отсутствии контакта с вероятными больными в срок не менее 14 дней до даты отъезда.\n\n"
+ "Клубный этаж\n"
+ "Отель Имеретинский 4*\n"
+ "Прибрежный квартал\n"
+ "Морской квартал\n"
+ "Заповедный квартал\n"
+ "Парковый квартал\n\n"
+ "Есть варианты в других кварталах. Выберите один из них для просмотра:\n\n"
+ "Клубный этаж\n"
+ "Отель Имеретинский 4*\n"
+ "Прибрежный квартал\n"
+ "Морской квартал\n"
+ "Заповедный квартал\n"
+ "Парковый квартал\n\n"
+ "Обращаем Ваше внимание!\n"
+ "В случае отсутствия при заселении подлинников документов, администрация гостиничного комплекса будет вынуждена отказать в заселении.\n\n"
+ "Принимая весь комплекс мер по рекомендациям Роспотребнадзора, мы проводим постоянные профилактические мероприятия для недопущения распространения инфекции.\n\n"
+ "Мы желаем вам крепкого здоровья и ждем в Сочи. Гарантируем вам яркий, незабываемый и самое главное безопасный отдых!\n\n"
+ "Настоящий сайт поддерживает 256-битное шифрование. Конфиденциальность сообщаемой персональной информации обеспечивается ПАО СБЕРБАНК. Введённая информация не будет предоставлена третьим лицам за исключением случаев, предусмотренных законодательством РФ. Проведение платежей по банковским картам осуществляется в строгом соответствии с требованиями платёжных систем МИР, Visa Int., MasterCard Europe Sprl, JCB.\n\n\n\n"
+ "Бронирование номеров и апартаментов онлайн\n\n"
+ "Комфортный отдых на черноморском побережье – в апарт-отеле или четырехзвездочном отеле гостиничного комплекса «Имеретинский», расположенном на первой береговой линии. Роскошные виды на горы Кавказа и Черное море. Все типы размещения, от стандартных номеров до просторных апартаментов площадью более 150 м². На этой странице вы можете забронировать номер онлайн.\n\n"
+ "Наш гостиничный комплекс предлагает комфортные варианты размещения для каждого гостя: номер или апартаменты любой площади, с кухней или без нее, с видом на море или бассейн, в тихом месте или поближе к яхтенной марине и пляжу. Предусмотрены максимально удобные условия для маломобильных граждан. Также вы можете онлайн забронировать номер с дополнительными привилегиями на Клубном этаже.\n\n"
+ "Поехали!\n"
+ "ПОПУЛЯРНЫЕ РАЗДЕЛЫ\n"
+ "Специальные предложения\n"
+ "Рестораны и бары\n"
+ "Развлечения\n"
+ "Услуги\n"
+ "Отдых с детьми\n"
+ "Фитнес-центр\n"
+ "SPA-салон\n"
+ "Лечение и медицина\n"
+ "Организация мероприятий\n"
+ "Открытые площадки\n"
+ "Программа лояльности\n"
+ "Агентствам\n"
+ "Контакты\n"
+ "О нас\n"
+ "РАЗМЕЩЕНИЕ\n"
+ "Отель «Имеретинский»\n"
+ "Апартаменты\n"
+ " Морской квартал\n"
+ " Прибрежный квартал\n"
+ " Парковый квартал\n"
+ " Заповедный квартал\n"
+ "Стоимость и бронирование\n"
+ "Регистрация онлайн\n"
+ "СВЯЗАТЬСЯ С НАМИ\n"
+ "8 800 707 77 22\n"
+ "ЗАКАЗАТЬ ОБРАТНЫЙ ЗВОНОК\n"
+ "reservation@im-hotel.ru\n"
+ "354340, Россия, г. Сочи, Имеретинская низменность, Морской бульвар, 1\n"
+ "↑\n"
+ "Подпишитесь на новости отеля «Имеретинский» и получите скидку: 10% на проживание\n"
+ "ПОДПИСАТЬСЯ\n"
+ "Нажимая на кнопку Вы соглашаетесь с Политикой работы с персональными данными, а так же даете СОГЛАСИЕ на обработку персональных данных\n"
+ "На побережье Чёрного моря\n"
+ "ОТКРЫТЬ В GOOGLE MAPS\n"
+ "РазработаноHotel commerce\n"
+ "Официальный сайт гостиничного комплекса «Имеретинский». © 2020 Все права защищены.\n"
+ "Продолжая использовать наш сайт, вы соглашаетесь с условиями использования файлов cookie.\n"
+ "Отправьте нам сообщение \"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}