using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(process)+(.*)(\n.*)*(?=Edition)";
string input = @"Throughout the book we’ve seen a variety of ways in which the shell processes input lines, especially using read. We can think of this process as a subset of the things the shell does when processing
command lines. This appendix provides a more detailed description of the steps involved in processing the command line and
how you can get bash to make a second pass with eval. The material in this appendix also appears in Learning the bash Shell, 3rd Edition, by Cameron Newham (O’Reilly).";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}