re = /(process)+(.*)(\n.*)*(?=Edition)/
str = 'Throughout the book we’ve seen a variety of ways in which the shell processes input lines, especially using read. We can think of this process as a subset of the things the shell does when processing
command lines. This appendix provides a more detailed description of the steps involved in processing the command line and
how you can get bash to make a second pass with eval. The material in this appendix also appears in Learning the bash Shell, 3rd Edition, by Cameron Newham (O’Reilly).'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end