package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[([^][]*(?:(?R)[^][]*)*)]`)
var str = `[a[b]d]abcasderfg
sss sss
[a[b]d]abcasderfg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}