$re = '/\[([^][]*(?:(?R)[^][]*)*)]/m';
$str = '[a[b]d]abcasderfg
sss sss
[a[b]d]abcasderfg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);