$re = '/\'[^=]+=[^\']+\'/';
$str = '/\'Team1 = 6\', while /\'Team2 = 4\', and /\'Team3 = 2\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);